Ajax Control Toolkit for SharePoint 2013


Is any version of AjaxControlToolkit supported for SharePoint 2013? I tried to use framework version 4 and 4.5 with SharePoint 2013 but couldn't make it working.
Closed Mar 13 at 12:32 PM by fadilmamedov
This ticket was merged with item 26867


kbrimington wrote Oct 23, 2013 at 6:31 PM

I have long been a fan of the Ajax Control Toolkit; however in SharePoint 2010 we were compelled to stick with a very old version, and now in SharePoint 2013 I cannot get any to work.

I deploy the assembly to the GAC, add appropriate <%@ Assembly %> and <%@ Register %> directives on the master page, swap the ScriptManager for a ToolkitScriptManager, and I get the yellow screen of death, with this message:
"The requested script resource 'AjaxControlToolkit.Common.Common.js' requires version 'AjaxControlToolkit, Version=, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e' of the ASP.NET AJAX Framework. To use this resource, make sure that the application references version 'AjaxControlToolkit, Version=, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e'. "
The application cannot reference AjaxControlToolkit. It is SharePoint. I cannot determine a workaround, and there appears to be absolute silence on the use of the ACT in SharePoint 2013. The impact of this issue is not Low, because it renders the entire toolkit unusable within SharePoint.

I would love to see workarounds or updates that allow us to use this tool; however, as it stands, we must abandon the tool and refactor our customizations to use something else. Incredibly disappointing!

ricky_lubana wrote Jun 30, 2014 at 6:24 PM

I have the same issue and got the same error as described above. Any update on which version of Ajax control toolkit to use with SharePoint 2013?