This project is read-only.
1

Closed

NuGet Package Manager Instatll Error - File contains corrupted data.

description

I tried installing this through the NuGet Package Manager and I am getting a "File contains corrupted data" error and through the Package Manager Console:

PM> Install-Package AjaxControlToolkit
Attempting to resolve dependency 'AjaxMin (≥ 4.97.4951.28483)'.
Attempting to resolve dependency 'HtmlAgilityPack (≥ 1.4.6)'.
Install-Package : File contains corrupted data.
At line:1 char:16
  • Install-Package <<<< AjaxControlToolkit
    • CategoryInfo : NotSpecified: (:) [Install-Package], FileFormatException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Am I doing something wrong or what do I need to do to correct this. I even tried creating a new blank project and installing but still got the same error so I don't think it's my actual VS solution.

Thanks
Closed Mar 20, 2015 at 3:55 PM by MikhailTymchukDX
Thank you for sharing your experience!

comments

dkr0001 wrote Sep 12, 2014 at 2:29 AM

I get the same error while installing AjaxControlToolKit in VS 2012 and .NET 4.5. Do we need to install AjaxMin and HtmlAgilityPack. Tried to install AjaxMin, it worked but, HtmlAgilityPack installed was corrupted as well.

Can we install Ajax 4.0 version for VS2012 and .NET 4.5 web applications?

My two days have gone invain trying to install and use an Ajax Autocomplete extenter in my new project.

Any help is appreciated. Thanks

phxgeeks wrote Sep 16, 2014 at 5:13 PM

I hope I'm not too late to help, but this is what I did and it worked.

I use VS2012. Go to Tools > Extensions and Update. Select NuGet Package Manager. I had version 2.0.6 so I uninstalled and reinstalled to v2.8.50313.

After restarting VS i went to Project > Manage NuGet Packages. It took longer for the list to load but was finally able to install everything I needed, including the HtmlAgilityPack.

Hope this works for you.

dromero14 wrote Nov 12, 2014 at 12:44 AM

@phxgeeks that worked for me. Great!